[OCFD-SRV043] Can’t connect to host
Applies to
OSLC Connect for Windchill 3.5+
OSLC Connect for Jira 2.7+
OSLC Connect for Confluence 1.1+
Problem
Admin entered a Root Services URL which the OSLC Connect tool failed to connect to.
Cause
Connection to the OSLC Remote Application fails with ConnectException
.
Resolution
You may want to check the following step by step:
open the Root Services URL from your browser
if a document (that is not an error) is displayed or downloaded, then it means that the server is up and running
else, you will need to ensure with the person responsible for the OSLC Remote Application’s server it is up & running, as well as the OSLC Remote Application itself
if you’re told the server is up and running and you still can’t access the Root Services URL
you will want to confirm that you can reach the application at all. Any URL expected to work to reach that application can be tested
if you can’t reach the application at all
reach out to your IT support so that they enable communication between your computer and the OSLC Remote Application’s server. They may check the port is opened, the firewall is allowing communication, the routers enable transparent communication between the networks of both applications…
if you can reach the OSLC Remote Application but you still can’t access the Root Services URL
you will want to confirm the OSLC services have been properly installed / enabled with the person responsible for the OSLC Remote Application, in case those services are optional or an add-on
when the server is up and running, you can reach the Root Services URL, and still the problem persists
reach out to your IT support so that they enable communication between your application’s server and the OSLC Remote Application’s server