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[OCFD-SRV058] Host name cannot be resolved

Applies to

  • OSLC Connect for Windchill 3.5+

  • OSLC Connect for Jira 2.7+

  • OSLC Connect for Confluence 1.1+

Problem

The Admin tried to add a friend whose URL cannot be reached by the OSLC Connect application

Cause

When the Admin enters a Root Services URL for the OSLC Remote Application, that URL is sent over to the OSLC Connect server for registration. Even if the Admin can reach the Root Services URL from her or his browser of choice, the OSLC Connect server may very well not have access to the OSLC Remote Application’s server. Connection to the OSLC Remote Application fails with UnknownHostException.

Resolution

You may want to check the following step by step:

  • open the Root Services URL from your browser

    • if a document (that is not an error) is displayed or downloaded, then it means that the server is up and running

    • else, you will need to ensure with the person responsible for the OSLC Remote Application’s server it is up & running, as well as the OSLC Remote Application itself

  • if you’re told the server is up and running and you still can’t access the Root Services URL

    • you will want to confirm that you can reach the application at all. Any URL expected to work to reach that application can be tested

  • if you can’t reach the application at all

    • reach out to your IT support so that they enable communication between your computer and the OSLC Remote Application’s server. They may check the port is opened, the firewall is allowing communication, the routers enable transparent communication between the networks of both applications…

  • if you can reach the OSLC Remote Application but you still can’t access the Root Services URL

    • you will want to confirm the OSLC services have been properly installed / enabled with the person responsible for the OSLC Remote Application, in case those services are optional or an add-on

  • when the server is up and running, you can reach the Root Services URL, and still the problem persists

    • reach out to your IT support so that they enable communication between your application’s server and the OSLC Remote Application’s server

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